Underground Mine Design in Surpac Vision

September 2006
Copyright © 2006 Surpac Minex Group Pty Ltd (A Gemcom Company). All rights reserved.

This software and documentation is proprietary to Surpac Minex Group Pty Ltd.

Surpac Minex Group Pty Ltd publishes this documentation for the sole use of Surpac licenses. Without written permission you may not sell, reproduce, store in a retrieval system, or transmit any part of the documentation. For such permission, or to obtain extra copies please contact your local Surpac Minex Group Office.

Surpac Minex Group Pty Ltd
Level 8 190 St Georges Terrace
Perth, Western Australia 6000
Telephone: (08) 94201383
Fax: (08) 94201350

While every precaution has been taken in the preparation of this manual, we assume no responsibility for errors or omissions. Neither is any liability assumed for damage resulting from the use of the information contained herein.

All brand and product names are trademarks or registered trademarks of there respective companies.

About This Manual

This manual has been designed to provide a practical guide to the many uses of the software. The applications contained within this manual are by no means exhaustive as the possible uses of the software are only limited by the user’s imagination. However, it will give new users a starting point and existing users a good overview by demonstrating how to use many of the functions in Surpac Vision. If you have any difficulties, or questions while working through this manual feel free to contact your local Surpac Minex Group Office.

Contributors

Rowdy Bristol
Phil Jackson

Surpac Minex Group
Perth, Western Australia

Product
Surpac Vision v5.2
# Table of Contents

Introduction ............................................................................................................................... 1  
Requirements .......................................................................................................................... 1  
Objectives .............................................................................................................................. 1  
Workflow .................................................................................................................................. 2  
Underground Design Concepts ............................................................................................... 3  
Creating a Centreline Design .................................................................................................. 4  
   1. Viewing the data ............................................................................................................... 4  
   2. Creating a centreline between ore zones................................................................. 5  
   3. Creating access drives to the ore zones ................................................................. 9  
   4. Creating the main decline ..................................................................................... 15  
   5. Creating a DTM from centrelines and profiles .................................................. 25
Introduction

There are many types of designs employed in underground mining. Although there are numerous requirements for each design, Surpac can assist you to create practically any type of mine design.

Requirements

Prior to proceeding with this tutorial, you will need:

- Surpac Vision v5.2 installed
- The dataset accompanying this tutorial

Objectives

The objective of this tutorial is to allow you to understand some of the string editing tools available in Surpac to create a decline and production access points into stopes.
Workflow

The process of performing underground mine design described in this tutorial is but one of many different approaches. There is no single set of steps which is generally employed in the process. You may want to start from the top and go down, from the bottom and design up, or start in the middle of the deposit and proceed up and down at the same time. The workflow you adopt will generally be the one which you find best for your scenario.

In this example the workflow is as follows:

```
Workflow

The process of performing underground mine design described in this tutorial is but one of many different approaches. There is no single set of steps which is generally employed in the process. You may want to start from the top and go down, from the bottom and design up, or start in the middle of the deposit and proceed up and down at the same time. The workflow you adopt will generally be the one which you find best for your scenario.

In this example the workflow is as follows:

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```

```
Underground Design Concepts

Overview

To create an underground mine design using Surpac requires an understanding of underground mining terminology and concepts. This section will cover some terms used in this tutorial and some basic concepts of underground mine design.

Requirements

Prior to performing the exercises in this chapter, some experience in underground mine design is helpful, but not required.

Terminology

- Centreline – a line which represents the centre of a drive. The centreline can be used to create solid models, or outlines for plan view plots.
- Drive – a tunnel, or opening in rock, also known as a drift, or crosscut
- Stope – a 3-dimensional area (usually ore) which is to be mined out by blasting a series of long holes or ring design holes

Underground Mine Design Concepts in Surpac

There are many different scenarios where underground mine designs are to be created. In this tutorial, we will use:

- 3D solid models of designed stopes.
- strings representing ore outlines at each level where a design is to be created.
- a point representing the location on the surface which is an entrance to the underground mine.

We will open files containing this data into graphics, then use various editing and point creation tools to create the underground mine design.

Summary

You should now be familiar with some of the concepts and terms used for underground design in Surpac. Review this chapter or consult the Online Reference Manual if you are unclear about the definitions used in this section. The next section demonstrates the steps involved in creating an underground design centreline.
Creating a Centreline Design

Overview

An underground design begins with the centreline. The creation of a centreline can be performed by many different functions within Surpac Vision, but is basically the creation of three dimensional points in space.

Requirements

Prior to performing the exercises in this chapter, you should have:

- a basic knowledge of Surpac string files and editing tools, as covered in the Introduction manual

1. Viewing the data

Open the file stopes1.dtm by dragging it into Graphics. This file represents two parallel ore zones.

Open the file ugdes_final1.dtm (may be in either the same layer or in a different layer - it does not matter).

The file ugdes_final1.dtm is the end result of what we will be creating in this tutorial. It is a series of three-dimensional solid objects representing an underground mine design.

The transparency of the ore zones can be controlled by setting the transparency colour for the faces of object 8 to grey, or an RGB value of something like $r=0.7 \ g=0.7 \ b=0.7$

To set the transparency colour, from the Customise menu, select Display properties, then DTM and 3DMs. The display properties will be activated for the current layer only.

From the View menu, select Surface view options, then Hide triangle faces to turn the faces off. From the Display menu, select Strings, then With string numbers to display strings 2 to 11.

Strings 2 to 11 represent the centreline string numbers in the final design we will be creating.
When you are finished viewing the data, select the Reset Graphics icon:

2. Creating a centreline between ore zones

We will now create a centreline midway between the two ore zones at the 200 level.

Open the file lev215.str into a new layer.

This can easily be done by clicking and dragging the file in the navigator into the graphics viewport, or by double clicking the file name in the navigator. Either of these actions will result in the file being opened into a layer named lev215.str.

The file lev215.str represents a small part of the existing workings at the 215 level. String 215 is the outline of the existing workings, and string 1 is the design centreline.

This is the point at which the production crew will begin mining to implement our design. As you will see, although mining will begin at this point, we do not necessarily have to begin the design at this point. In our case, we will actually begin the design at the ore zone, and work back to this point. This is just one way of creating an underground mine design for this data set. The main objective of this tutorial is to teach you the tools for creating an underground design. The manner in which you use these tools is up to you.

Open the file stopes1.str into a new layer, and spin the data around to get an idea of how the strings are formed in 3D space.

From the Display menu, select Strings, then With string numbers to display all string numbers.

From the Inquire menu, select Point properties, and select several different segments.

Notice that the string numbers are the same as the Z value of the strings.

We will now create a design from the 200 level up to lev215.str, starting at the 200 level.

From the Display menu, select Hide everything.

From the Display menu, select Strings, then With string numbers, and display only string 200.
Set main graphics layer as the current layer. Note that main graphics layer contains nothing at this point.

As shown in the final design image shown previously, the string number used to create the main drive between the two ore zones is string 10.

From the Create menu, select Digitise, then Properties (or use the design string number button, displayed in the status bar at the bottom of the main Surpac window) to set the design string number, which will currently be set to string number 1:

On the form that pops up, set the design string number to 10, and click Apply

From the Create menu, select Digitise, then New midpoint, and select two points on the north end of the ore zones to create a point halfway between the two selected points, as shown:

From the Create menu, select Digitise, then New midpoint, and select two points on the south end of the ore zones to create a point halfway between the two selected points, as shown:

Click escape to terminate the input to the function. The Z value of the points will be equal to the average of the Z values of the two selected points. In this case, where the Z value of both points is 200, the Z value of the new points will be 200.

Next, suppose we want to move the end of the drive (the first point created) 50 meters to the southeast, along the line between the two points.
First, set the **mode** to **Change** by selecting the item from the **Status Items** toolbar.

From the **Create** menu, select **Points**, then **Online between any points**.

Select the first point created in string 10 (the point to be moved), then select the second point created in string 10.

On the form, select **Horizontal Distance**, enter a distance of 50, and **Apply** the form.

The first point will be moved 50 meters as shown below:

Click escape to terminate the input to the function. Next, we will create points along the centreline every 50 meters from the first point (the northern end of the drive) to the second point (the southern end of the drive).
To create points in the same segment, we need to set the mode to Insert. Change the mode from Change to Insert.

From the Create menu, select Points, then Multiple points by subdividing.

Select the northern end of string 10, then the southern end of string 10.

Enter the following, then Apply the form:

![Subdivide a Line dialog box](image)

New points will be created every 50 meters from the first point to the second point. Click escape to terminate the input to the function.

From the Display menu, select Point, then Numbers, and Apply the form to display point numbers for all points in the main graphics layer.

You will see that points 2, 3, and 4 have now been inserted in between the northern endpoint and the southern endpoint of the centreline:

![Diagram showing points 2, 3, and 4](image)

These points will serve as the starting points for the access points to the ore zones.

Save the centreline string to the file ugedes1.str
If you want to see all of the steps performed in this chapter, either run or edit:

_01_create_centreline_between_ore_zones.tcl

Note: If the macro pauses, displaying “Click in graphics to continue” in the message window, you will need to click in graphics to allow the macro to continue. Also, you will need to **Apply** the forms presented.

3. **Creating access drives to the ore zones**

We will now create centrelines for these access drives from string 10 to the ore zones.

Select the design string button on the status bar at the bottom of the main Surpac window (currently displaying Str = 10).

Enter a new design **string number** of 11, and **Apply** the form:

![Set the Design String Number](image)

Change the **mode** to Add.

![Add](image)

From the Create menu, select **Points**, then **By angle**.

Select point 2, then point 1.

Enter a Distance of 0 and an Angle of 0, and **Apply** the form:

![Locate Point by Angle, Distance and](image)

This is only one way of creating a point in string 11 at the same location as point 1 in string 10.
Next, we will create the endpoint of the access drive with the same function.

Without cancelling the previous function, once again select point 2, then point 1 as before, enter the following, then **Apply** the form:

![Locate Point by Angle, Distance angle...](image)

This will now create a new segment of string 11 that will extend beyond the western ore zone. We will clip this to the edge of the ore zone later.

![Diagram](image)

From the **Create** menu, select **New segment**.

We need to do this between segments so that the end of the first segment is not connected to the beginning of the second segment.

From the **Create** menu, select **Points**, then **By angle**.

Select point 2, then point 1 again, enter a **Distance** of 0 and an **Angle** of 0, and **Apply** the form:
Without cancelling the previous function, once again select point 2, then point 1 as before, enter the following, then Apply the form:

We will now have two segments of string 11 representing the centreline of ore access drives left and right off the main drive.

From the Display menu, select Hide temporary markers to remove the small markers created when you create or identify a point.

We will now copy both segments of this string to points 2, 3, and 4.

Using the combobox on the Status Items toolbar, set the mode from No Snap to Point.
From the **Edit** menu, select **String**, then **Copy**.

Select string 11 near point 1, and drag to point 2.

In order to correctly select a string or segment in Surpac Vision, **DO NOT** select a point common to two or more strings. In this case, in order to select string 11, you would not want to position the cursor right on top of point 1, as this point is common to string 10 and string 11, and you could not be certain exactly which string you will select. Instead, select the line near the point, as shown:

![Incorrect](image1) ![Correct](image2)

After selecting string 11 as shown above, and dragging it to point 2, release, fill in the form as follows, and **Apply** the form:

![Copy a String](image3)

A copy of both segments of string 11 will now be created at point 2:

![Copy a String Result](image4)

Note that there are exactly two additional points on string 10 (point 3 and point 4) where we need access drives. We can simply continue the **String Copy** function to create drives for these points.
While still in the function **String Copy**, select string 11 again near point 1. Drag to point 3, release, fill in the form as before, and **Apply** the form:

![Copy a String dialog box]

Click Escape to terminate the input to the function.

Now all eight access drives are created:

![Diagram of access drives]

The last step is to trim the access drives back to the ore zones.

From the **Edit** menu, select **Trim**, then **Clip by selected segment**. Select **inside**, then **Apply** the form:

![Select and Clip Data dialog box]

Select one segment of string 200.

All portions of segments inside the selected ore zone will be removed. When the form appears again, leave it set to **inside** and **Apply** the form:

![Select and Clip Data dialog box]

Select the other ore zone.

When the form appears again, **Cancel** it.
You should now see all portions of segments inside both ore zones removed:

All that remains to do is to remove the portions of string 11 extended beyond the ore zones.

From the **Edit** menu, select **Segment**, then **Delete**, and select the portion of each segment extended beyond the ore zones.

From the **Display** menu, select **Hide temporary markers**.

When you are finished, you should see the following:

Save the file again as **ugdes1.str**, overwriting the previous contents.

If you want to see all of the steps performed in this chapter, either run or edit:

```
_02_create_access_drives_to_ore_zones.tcl
```

Note: If the macro pauses, displaying "Click in graphics to continue" in the message window, you will need to click in graphics to allow the macro to continue. Also, you will need to **Apply** the forms presented.
4. Creating the main decline

We will now create the decline from the access point on the 215 level to the southern end of the main drive between the two ore zones, as illustrated below. The curve numbers given here will be referred to throughout the remainder of this section of the tutorial.

Prior to commencing this design, here are a few design constraints:

- The gradient from the Access Point to the Start of the Decline will be flat.
- The gradient from the Start of the Decline to the End of the Decline can be no more than 15%.
- Curve 1 will have a radius of 20 meters.
- Curves 2 and 3 will have a radius of 30 meters.
- There must be a 5 meter straight section between curves 2 and 3.

Make lev215.str the active layer
From the Display menu, select Strings, then With string numbers, to display all strings in the layer.

As was previously mentioned, string 215 is the outline of the existing workings, and string 1 is the design centreline. The end of string 1 is the point which our design must tie into the existing workings. For this tutorial, it will be referred to as the "Access Point". Both strings represent the actual elevation of the floor. We need to know the elevation of the Access Point, and of point 5 on string 10 (labelled as "End of Decline" in the previous design image).

From the Inquire menu, select Point properties to determine the elevation of the two points.

You should get:

Elevation of Access Point: 216.98
Elevation of End of Decline: 200

Thus, we have to travel 16.98 meters vertically to get from the access point to the end of the decline.

We will also need to know the bearing of the design centreline (string 1) of lev215.str, and the bearing of string 10 in ugdes1.str.

From the Inquire menu, select Bearing and Distance between two points. Select the end of string 1, then the beginning of string 1.

You should get:

Bearing = 255.0000

Click the escape key to stop the function. Zoom out to see the access drives then zoom in to get a good view of points 4 and 5. Rerun the Bearing and Distance function and select point 5, then point 4 on string 10 in ugdes1.str. Click the escape key to stop the function.

You should get something close to:

Bearing = 334.3332

We can calculate that the angular travel to get from the first bearing to the second bearing is:

334.3332 - 255.0000 = 79.3332 degrees

From the information above, we know that we want the gradient from the Access Point to the Start of the Decline to be flat. So, we will make curve 2 rotate through 79.3332 degrees, and curve 3 rotate through 90 degrees. We can construct this curve, grade it to 15%, and then determine how much we need to move it, if at all. Alternatively, we could do all of the calculations by hand, and construct the curve in the correct location to start with. In this example, we will create the curve first, and then move it.

Set the main graphics layer as the current layer, the mode to Add, Snap to No Snap and the design string as 10. Leave the design gradient set to zero percent for now:
From the **Display** menu, select **Point**, then **Numbers** to display the point numbers for string 10.

From the **Display** menu, select **Point**, then **Markers** to display the point markers for string 10.

From the **Create** menu, select **Curve at segment end**.

Select point 4, then point 5. Enter the data as shown, and **Apply** the form:

![Parameters for a Curve at End of Line](image)

You now need to join the straight section with the curve.

From the **Edit** menu, select **Segment** then **Join**. Select point 5, then point 7.

Since the bearing of the main drive between the ore zones was 334.3332, we will construct the 5 meter straight section at a bearing 90 degrees less than that, or 244.3332.

From the **Create** menu, select **Points**, then **By bearing**. Select the end of the newly created curve. Enter the following and **Apply** the form:

![Locate Point by Bearing, Distance a...](image)

A single point will be created, adding onto the existing segment of string 10.

Click and drag the right mouse button or use the mouse wheel to zoom in on the data.
From the **Display** menu, select **Point**, then **Numbers** to display point numbers for string 10.

From the **Create** menu, select **Curve at segment end**. **Select** point 21, then point 22.

Enter the following and **Apply** the form:

```
Note that the direction of the curve is anticlockwise. Click escape to terminate the input.
```

From the **Display** menu, select **Point**, then **Markers** to display the markers on string 10.

From the **Display** menu, select **Point**, then **Numbers** to display the point numbers for string 10.

From the **Display** menu, select **Hide temporary markers**.

You should now see the following curve:

```
We will now grade the segment, and determine the elevation of point 36, at the end of the decline curve.
```
From the **Edit** menu select **Segment**, then **Change gradient**.

Select point 5, then point 36, and enter the following:

![Grade a Segment dialog box](image)

From the **Inquire** menu, select **Point properties**, then select point 36.

You should see something like:

\[
Z=214.049
\]

Recall that the elevation of the Access Point is 216.98. Thus, the amount of vertical distance yet to travel is:

\[
216.98 - 214.049 = 2.931 \text{ meters}
\]

This translates to a horizontal distance of:

\[
2.931 / 0.15 = 19.54 \text{ meters}
\]

We could append this onto the southern end of curve 2, but to illustrate another couple of tools, we will instead move both curves 2 and 3 at a bearing of 334.3332 degrees by a distance of 19.54 meters, and then regrade the segment. To do this, we first need to break the curves away from the main drive.

From the **Edit** menu, select **Segment**, then **Break**, then select between points 5 and 6.

From the **Edit** menu, select **Move segment constrained by**, then **Bearing and distance**.

Select the segment comprising the two curves, enter the following and **Apply**:

![Move a Segment by Bearing and Dip dialog box](image)
You should now see the segment moved at a bearing of 154.3332 19.54 meters:

We will now reconnect and regrade the curves.

From the **Edit** menu, select **Segment**, then **Join**. Select the main drive first (at point 5), then select the curves.

From the **Edit** menu, select **Segment**, then **Change gradient**. Select point 5, then point 36, enter the following, and **Apply**:

![Grade a Segment](image)

From the **Inquire** menu, select **Point properties**, then select point 36 (i.e. the southern end of curve 2).

You should see something like:

Z=216.979

Recall that the elevation of the Access Point is 216.98. Thus, the southern end of curve 2 is now at the same elevation as the Access Point.

Knowing that the bearing of the centreline of the Access Point is 255.0000, and assuming that we have constructed our previous curves correctly, the bearing of a line perpendicular to the centreline of the Access Point (as well as being tangent to the last point on curve 2) will be 90 degrees less than that, or 165 degrees.
We will now employ a couple of other tools to create curve 1.

From the **Create** menu, select **Points**, then **By bearing**. Select the southern end of curve 2, enter the following, and **Apply** the form.

![Image](image.png)

A new point will now be created much further south than required:

Click escape to terminate the function. We will now move this point (number 37) to the location where it will be in line with both the line just created, and with the centreline of the Access Point.

Set the **mode** to **Change**:  

![Mode options](image2.png)
From the **Create** menu, select **Points**, then **At intersection of two lines**.

Select point 37 first, then point 36. It is important to select 37 first, as the first point selected will be moved.

Next, select both of the endpoints of the centreline of **lev215.str** (string 1).

You may need to use the **Assist key** (F1) to allow you to zoom in on **lev215.str** so that you select the correct points. It does not matter which end you select first for this string. Point 37 will be moved to the correct position:

Click escape to terminate the function. We will now attach the decline string directly to the Access Point.

Set the **snap mode** to **Point**:

From the **Create** menu, select **Points**, then **Insert after an existing point**.

Select point 37 and drag it to the Access Point.

Click Escape to terminate the function.
You should now see the following:

Click escape to terminate the function. We will now create curve 1 (with a radius of 20 meters) at point 37.

Set the **mode** to **Insert**:

From the **Create** menu, select **Curve from tangents**.

Select point 36, then point 37.

Select point 37 again, then point 38.

Enter the following and **Apply** the form:
You should now see something like the following:

Save the file as **ugdes1.str**, overwriting the previous copy. If you want to see all of the steps performed in this chapter, either run or edit:

```
_03_create_main_decline.tcl
```

Note: If the macro pauses, displaying “Click in graphics to continue” in the message window, you will need to click in graphics to allow the macro to continue. Also, you will need to **Apply** the forms presented.
5. Creating a DTM from centrelines and profiles

We will now use the centre line and two types of profiles to create the dtm corresponding to the underground drives. Firstly, we will look at the two different types of profiles we will use.

Open the file `drive_profile3x3.str` by dragging it into graphics. From the View menu, select Zoom, then Out. From the Display menu, select Strings, then With colour fill. Add a 2D grid by clicking on the icon and selecting a 1m by 1m mesh size. You should see something like the diagram below.

Open the file `drive_profile4x3_5.str` by dragging it into graphics. From the View menu, select Zoom, then Out. From the Display menu, select Strings, then With colour fill. Add a 2D grid by clicking on the icon and selecting a 1m by 1m mesh size. You should see something like the diagram below.
Clear the graphics area by clicking on the \( \times \) icon.

To compare the two profiles, open file `drive_profile3x3.str` by dragging it into graphics, then open file `drive_profile3x4_5.str` in graphics. From the View menu, select Zoom, then Out

Add a 2D grid by clicking on the \( \square \) icon and selecting a 4m by 4m mesh size.

You should see something like the following:

![Diagram](image1.png)

Note that both of the profiles are centred at point 0,0 on the floor of the profile.

If you want to see all of the steps performed in this chapter, either run or edit:

`_05a_display_profiles.tcl`

Note: If the macro pauses, displaying “Click in graphics to continue” in the message window, you will need to click in graphics to allow the macro to continue. Also, you will need to click Apply on any forms presented.
We will now produce the dtm by triangulating using the centreline and profiles.

Clear the graphics area by clicking on the X icon. Open the file *ugdes1.str* by dragging into graphics.

From the **Underground design** menu, select **Tools**, then **Triangulate using centreline and profile**. Fill in the form as shown below and click **Apply**.

![Triangulate Centre Line and Profile dialog box](image)

Note that this profile is applied to string 10 only, i.e. the centreline string.

You should see something like the following:
Next we will triangulate the ore access drives, which are in string 11. From the **Underground Design** menu, select **Tools**, then **Triangulate using centreline and profile**. Fill in the form as shown below and click **Apply**.

You will need to click on each individual segment to create all of the access drives.

![Triangulate Centre Line and Profile dialog box](image)

When finished, you should see the following:

![Triangulated access drives](image)
Next we will validate the solid we have created. From the **Solids** menu, select **Validation**, then **Validate** object.

![Set Neighbours and Validate Objects](image)

From the **Solids** menu, select **Validation**, then **Set object to solid or void**. Click in the checkbox to select to a solid, then click **Apply**.

![Set Triangle Directions for Objects](image)

The dtm and string file have now been created. Save the DTM and string files before continuing.

If you want to see all of the steps performed in this chapter, either run or edit:

```
_05b_triangulate_centreline.tcl
```

Note: If the macro pauses, displaying “Click in graphics to continue” in the message window, you will need to click in graphics to allow the macro to continue. Also, you will need to click **Apply** on any forms presented.
As a final step will calculate the volume of material that would need to be extracted to create the underground mine from our design.

From the **Solids** menu, select **Solids tools**, then **Report volume of solids**. Fill in the form as shown below, then click **Apply**.

![Object Report](image)

The report will provide volumes for the centreline with the 4x3.5m profile and for the individual volumes of each of the 3x3m access drives. Note that in this case the drives are overlapping and so the total volume will not be an accurate reflection of the whole geometry.

If you want to see all of the steps performed in this chapter, either run or edit:

```
_05c_drive_volume.tcl
```

Note: If the macro pauses, displaying “Click in graphics to continue” in the message window, you will need to click in graphics to allow the macro to continue. Also, you will need to click **Apply** on any forms presented.

**Summary**

By completing all of the exercises in this tutorial, you will now know how to use many of the tools required for creating an underground centreline, and understand that there is more than one way to perform a task such as this in Surpac Vision. Please contact your local Surpac support office if you have any questions.